#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}"
Local $sString = "{ /*uninterested in this*/ " & @CRLF & _
""" & @CRLF & _
"digraph Checker " & @CRLF & _
"{ " & @CRLF & _
"/*bunch of stuff*/" & @CRLF & _
"{" & @CRLF & _
"/*bunch of stuff*/" & @CRLF & _
"}" & @CRLF & _
"{" & @CRLF & _
"/*bunch of stuff*/" & @CRLF & _
"}" & @CRLF & _
"{" & @CRLF & _
"/*bunch of stuff*/" & @CRLF & _
"}" & @CRLF & _
"/*bunch of stuff*/" & @CRLF & _
"} //first most curly brace ends, would want the regex to filter out till here, incl. the braces" & @CRLF & _
""" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")