package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}`)
var str = `{ /*uninterested in this*/
"
digraph Checker
{
/*bunch of stuff*/
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
/*bunch of stuff*/
} //first most curly brace ends, would want the regex to filter out till here, incl. the braces
"
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}