re = /digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}/i
str = '{ /*uninterested in this*/
"
digraph Checker
{
/*bunch of stuff*/
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
/*bunch of stuff*/
} //first most curly brace ends, would want the regex to filter out till here, incl. the braces
"
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end