Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[1-9]\d*(.\d+)?$
/
gm
Input 1
1
New
1.2345 123.45 123. .12345 0.1234 4.1234 4x1234 1-23455