re = /^[1-9]\d*(.\d+)?$/m
str = '1.2345
123.45
123.
.12345
0.1234
4.1234
4x1234
1-23455'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end