use strict;
my $str = 'i18(\'Grant (\\\'%s\\\') access to ALL users to feature: \', permission.toUpperCase());
alert(i18("These users already :") exist and were:") \', not added:") + :") ) xxx + "\\n\\n" + msg );
var msg;
if (permission == \'none\') {
msg = i18(\'This action will remove the rights for \\\'%s\\\' from feature: \', userName);
} else if (permission == \'complete\') {
msg = i18(\'Grant ALL rights for \\\'%s\\\' to feature: \', userName);
} else {
msg = i18(\'Grant (\\\'%s\\\') access for \\\'%s\\\' to feature: \', [permission.toUpperCase(), userName]);
}';
my $regex = qr/i18\s*\(\s*['"](.+)['"]\,.*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}