// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)i18\s*\(\s*['"](.+)['"]\,.*\)"#).unwrap();
let string = "i18('Grant (\\'%s\\') access to ALL users to feature: ', permission.toUpperCase());
alert(i18(\"These users already :\") exist and were:\") ', not added:\") + :\") ) xxx + \"\\n\\n\" + msg );
var msg;
if (permission == 'none') {
msg = i18('This action will remove the rights for \\'%s\\' from feature: ', userName);
} else if (permission == 'complete') {
msg = i18('Grant ALL rights for \\'%s\\' to feature: ', userName);
} else {
msg = i18('Grant (\\'%s\\') access for \\'%s\\' to feature: ', [permission.toUpperCase(), userName]);
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}