use strict;
my $str = '+49 711 4 20 42 26';
my $regex = qr/^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";