import re
regex = re.compile(r"(?<!(?=((http|https|ftp|ftps?)\:\/\/?)(www\.?)))Nissan(?!(?:([$&+.,/:;\-_#=@?!a-zA-Z0-9](?!\s))+))(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)(?! (Micra|is))", flags=re.IGNORECASE)
test_str = ("<p>Nissan is car manufacter odoocompany.</p>\n"
"<p>Nissan</p>\n"
"<p>Nissan. Nissan, Nissan: 'Nissan' \"Nissan\" Nissan. </p>\n"
"<p>niss 'Nissan' niss</p>\n"
"<p>[Nissan] (Nissan)</p>\n"
"<p>Nissan! www.Nissan.com and www.Nissan.co.in/?nissan=/Nissan.php </p>\n"
"<p>Nissan! www.Nissan.com/nissanis/nissan01/nissan_-ABC/nissan.com</p>\n"
"<p>nissan.com/nissan.html nissan company Nissan Micra is product</p>\n"
"<p><a href=\"www.Nissan.com\">Nissan</a> is company and <span><a href=\"www.Nissan.com\">Nissan</a></span> Micra is product</p>\n"
"<p><span>Nissan</span></p>\n"
"<p>Nissan product <a href=\"Nissan.com\">Nissan</a> ignore Nissan</p>\n"
"<p>nissan <a href=\"Nissan.com\"><span>Nissan</span></a> new nissan</p>\n"
"<p>odoo is a name Company and Nissan Micra is a model of best.</p>\n\n"
"<p>This is new <a href='https://www.Nissan.com'><span>Nissan</span></a> micra of micra nissan is company.\n"
"nissan is a company.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")