using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tel:(\+\d{1,20})";
string input = @"P-Asserted-Identity: ""Cullen Jennings"" <sip:fluffy@cisco.com>
P-Asserted-Identity: tel:+14085264000
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}