re = /tel:(\+\d{1,20})/
str = 'P-Asserted-Identity: "Cullen Jennings" <sip:fluffy@cisco.com>
P-Asserted-Identity: tel:+14085264000
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end