#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)Nissan(?!((?!<\/a>).)*<\/a>|((?!<\/span>).)*<\/span>)"
Local $sString = "Nissan" & @CRLF & _
"nissan" & @CRLF & _
"<span>Nissan</span>" & @CRLF & _
"<a href="nissan.com">Nissan</a>" & @CRLF & _
"<a href="nissan.com"><span>Nissan</span></a>" & @CRLF & _
"Company Nissan is a name. and Nissan Micra is model name. " & @CRLF & _
"Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name. " & @CRLF & _
"This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")