#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$"
Local $sString = "website.com" & @CRLF & _
"www.website.com" & @CRLF & _
"*.website.com" & @CRLF & _
"*x.website.com" & @CRLF & _
"x*.website.com" & @CRLF & _
"**.website.com" & @CRLF & _
"website.aaaaaaaaaaa" & @CRLF & _
"totally-not.a-sketchy.site" & @CRLF & _
"bad_website.com" & @CRLF & _
"web-site.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")