using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$";
string input = @"website.com
www.website.com
*.website.com
*x.website.com
x*.website.com
**.website.com
website.aaaaaaaaaaa
totally-not.a-sketchy.site
bad_website.com
web-site.net";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}