Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$
`
gm
Input 1
1
New
website.com www.website.com *.website.com *x.website.com x*.website.com **.website.com website.aaaaaaaaaaa totally-not.a-sketchy.site bad_website.com web-site.net