const regex = new RegExp('(?i)^(?:([a-z0-9-]+|\\*)\\.)?([a-z0-9-]{1,61})\\.([a-z0-9]{2,7})$', 'gm')
const str = `website.com
www.website.com
*.website.com
*x.website.com
x*.website.com
**.website.com
website.aaaaaaaaaaa
totally-not.a-sketchy.site
bad_website.com
web-site.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}