re = /(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$/m
str = 'website.com
www.website.com
*.website.com
*x.website.com
x*.website.com
**.website.com
website.aaaaaaaaaaa
totally-not.a-sketchy.site
bad_website.com
web-site.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end