// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$").unwrap();
let string = "website.com
www.website.com
*.website.com
*x.website.com
x*.website.com
**.website.com
website.aaaaaaaaaaa
totally-not.a-sketchy.site
bad_website.com
web-site.net";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}