use strict;
my $str = 'R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\\s)?(v[ée]lo)
R1_NOT = (parking) ([aà]\\s)?(v[ée]lo) avec bornes?
local vélo
local à vélo
rack à vélo
garage à vélo
emplacement à vélo
abri vélo
parking vélo
[NE PAS PRENDRE EN COMPTE]
parking vélo avec borne';
my $regex = qr/(parking) ([aà]\s)?(v[ée]lo) avec bornes? /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}