package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\/t(?:\/(\d+)\/[a-z_-]+\/?|op(\d+)\.html)$`)
var str = `good examples:
/t/2/title/
/t/98127/welcome_world-here/
/top1.html
/top2126.html
/top102542/120939.html
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}