const regex = /^(\+)|\D/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)|\\D', 'gm')
const str = `+41 456-7891+23`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);