using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{8})(?!$)";
string substitution = @"$1,";
string input = @"123456781234567812345678122";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}