const regex = /"(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?U)\\\\b[\\\\p{Upper}\\\\p{Space}\\\\p{Punct}]{2,}\\\\b"', 'g')
const str = `I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#\$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}