// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(?U)\\b[\\p{Upper}\\p{Space}\\p{Punct}]{2,}\\b""#).unwrap();
let string = "I HATE YOU;
1, 2, 3, GO!
ÄMLÄTS!
ZOMG THE %^*@#$(*^ ZOMBIES ARE COMING!!11!!1!
ÄMLäTS!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}