# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<textarea id[^>]*>\n([^\n]*)"
test_str = ("<div class=\"form-item form-type-textarea form-item-answer2\">\n"
"<div class=\"form-textarea-wrapper resizable\"><textarea id=\"edit-answer2\" name=\"answer2\" cols=\"60\" rows=\"5\" class=\"form-textarea\">\n"
"this is some text\n"
"</textarea>\n"
"</div>\n"
"</div>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.