// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<textarea id[^>]*>\n([^\n]*)").unwrap();
let string = "<div class=\"form-item form-type-textarea form-item-answer2\">
<div class=\"form-textarea-wrapper resizable\"><textarea id=\"edit-answer2\" name=\"answer2\" cols=\"60\" rows=\"5\" class=\"form-textarea\">
this is some text
</textarea>
</div>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}