import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "div class=\"form-item.*class=\"form-textarea\">[^\\n]*\\n\\K[^\\n]*";
final String string = "<div class=\"form-item form-type-textarea form-item-answer2\">\n"
+ "<div class=\"form-textarea-wrapper resizable\"><textarea id=\"edit-answer2\" name=\"answer2\" cols=\"60\" rows=\"5\" class=\"form-textarea\">\n"
+ "this is some text\n"
+ "</textarea>\n"
+ "</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}