package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Foo\s+Bar<br\s+\/>(.*)\s*<br \/>`)
var str = `Foo Bar<br />BAZ
<br />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}