#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/(?<resource>[\w\-]+)(?:/(?<id>(?!actions)[\w\-]+))?(?:/actions/(?<action>[\w\-]+))?"
Local $sString = "/resource" & @CRLF & _
"/resource/1" & @CRLF & _
"/resource/1/sub-resource" & @CRLF & _
"/resource/1/sub-resource/2" & @CRLF & _
"/resource/1/sub-resource/2/sub-sub-resource" & @CRLF & _
"/resource/1/sub-resource/2/sub-sub-resource/3" & @CRLF & _
"" & @CRLF & _
"/resource/actions/complete" & @CRLF & _
"/resource/1/actions/complete" & @CRLF & _
"/resource/1/sub-resource/actions/complete" & @CRLF & _
"/resource/1/sub-resource/2/actions/complete" & @CRLF & _
"/resource/1/sub-resource/2/sub-sub-resource/actions/complete" & @CRLF & _
"/resource/1/sub-resource/2/sub-sub-resource/3/actions/complete"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")