using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(?<resource>[\w\-]+)(?:/(?<id>(?!actions)[\w\-]+))?(?:/actions/(?<action>[\w\-]+))?";
string input = @"/resource
/resource/1
/resource/1/sub-resource
/resource/1/sub-resource/2
/resource/1/sub-resource/2/sub-sub-resource
/resource/1/sub-resource/2/sub-sub-resource/3
/resource/actions/complete
/resource/1/actions/complete
/resource/1/sub-resource/actions/complete
/resource/1/sub-resource/2/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/actions/complete
/resource/1/sub-resource/2/sub-sub-resource/3/actions/complete";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}