import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(?<resource>[\\w\\-]+)(?:/(?<id>(?!actions)[\\w\\-]+))?(?:/actions/(?<action>[\\w\\-]+))?";
final String string = "/resource\n"
+ "/resource/1\n"
+ "/resource/1/sub-resource\n"
+ "/resource/1/sub-resource/2\n"
+ "/resource/1/sub-resource/2/sub-sub-resource\n"
+ "/resource/1/sub-resource/2/sub-sub-resource/3\n\n"
+ "/resource/actions/complete\n"
+ "/resource/1/actions/complete\n"
+ "/resource/1/sub-resource/actions/complete\n"
+ "/resource/1/sub-resource/2/actions/complete\n"
+ "/resource/1/sub-resource/2/sub-sub-resource/actions/complete\n"
+ "/resource/1/sub-resource/2/sub-sub-resource/3/actions/complete";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}