#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(>)\s+(<)|\s+$"
Local $sString = "abc> <def" & @CRLF & _
"xyz>" & @CRLF & _
""
Local $sSubst = "$1(newcontent)$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)