#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?xsm) # free-spacing mode, DOTALL, multi-line" & @CRLF & _
"(?=.*?blue) # if blue isn't there, fail without delay" & @CRLF & _
"" & @CRLF & _
"########### LINE SKIPPER / COUNTER ############" & @CRLF & _
"(?: # start non-capture group" & @CRLF & _
" # the aim is to skip lines that don't contain blue" & @CRLF & _
" # and capture a corresponding digit sequence" & @CRLF & _
" (?: # skip one line that doesn't contain blue" & @CRLF & _
" ^ # beginning of line" & @CRLF & _
" (?:(?!blue)[^\r\n])* # zero or more chars" & @CRLF & _
" # that do not start blue" & @CRLF & _
" (?:\r?\n) # newline chars" & @CRLF & _
" ) " & @CRLF & _
"# With each line skipped, let Group 1 capture" & @CRLF & _
"# an ever-growing portion of the string of numbers" & @CRLF & _
" (?= # lookahead" & @CRLF & _
" .* # Go to the end of the file" & @CRLF & _
" ( # start Group 1" & @CRLF & _
" ~\d+ # match a tilde and digits" & @CRLF & _
" (?(1)\1) # if Group 1 is set, match Group 1" & @CRLF & _
" ) # end Group 1" & @CRLF & _
" ) # end lookahead" & @CRLF & _
")*+ # end counter-line-skipper: zero or more times" & @CRLF & _
" # the possessive + forbids backtracking" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".*? # lazily match any chars up to..." & @CRLF & _
"blue # match blue" & @CRLF & _
".* # Get to the end of the data" & @CRLF & _
"~ # match a tilde" & @CRLF & _
"\K # drop what we matched so far" & @CRLF & _
"\d+ # match digits. This is the match! " & @CRLF & _
"(?=(?(1)\1)) # if Group 1 has been set, match it" & @CRLF & _
""
Local $sString = "Paint it white" & @CRLF & _
"Paint it black" & @CRLF & _
"Why not blue?" & @CRLF & _
"Or red or brown?" & @CRLF & _
"" & @CRLF & _
"~10~9~8~7~6~5~4~3~2~1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)