const regex = /^(?=(?:\D*\d){1,9}\D*$)\d*(?:\.\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\D*\\d){1,9}\\D*$)\\d*(?:\\.\\d{2})?$', 'gm')
const str = `Match type:
.01
1
1.01
0
1234567.89
Unmatch type:
.012
1.098
123.456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}