import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,7}(?:\\.\\d{2}|\\d{0,2})$";
final String string = "Match type:\n\n"
+ ".01\n"
+ "1\n"
+ "1.01\n"
+ "0\n"
+ "1234567.89\n\n"
+ "Unmatch type:\n\n"
+ ".012\n"
+ "1.098\n"
+ "123.456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}