import Foundation
let pattern = #"bob(?!.*bob)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
joe,bob,luis,sancho,
bob,marco,lura,hannah,bob,marco,luis
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)