use strict;
my $str = 'Text to keep
//###==###
Text to remove
//###==###
Text to keep';
my $regex = qr/(^\s*^\/\/###==###.*?\/\/###==###\s*)/msp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";