$re = '/length ?= ?\"[\+\-]?\d+(?:\.\d+)?\".*height ?= ?\"[\+\-]?\d+(?:\.\d+)?\"/ms';
$str = '<house prize="2000000"
length="-1200"
owner="Smith"
height="55.8"/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);