# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?P<User>[a-zA-Z1-9\._]+)@(?P<Domain>[a-zA-Z1-9]+)\.(?P<D_EXT>[a-zA-Z]+)/${User} at ${Domain}.${D_EXT}\n/g;t' <<< "my email is andy@delusion.org
my school email is andrew.newton18@mydiscoveryk8.org
daddy's email is mike@delusion.org
Zach H's email is hitchcockzach@gmail.com
Zach R's email is zrambler441@yahoo.com
Ryan's email is ryanmeth@icloud.com
Mateo's email is mateo@relhok.com
Kieran's email is kieran.derrington@gmail.com
Tyler's email is tbone.vaughn@icloud.com
DON'T WORK:
...@.......
secreretface-2@loans.com
"