const regex = /Procedure:([\S\s]+)CLINICAL DIAGNOSIS/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Procedure:([\\S\\s]+)CLINICAL DIAGNOSIS', '')
const str = `SPECIMEN: Procedure: xxxx1 A) Location: yyyy2
Major zzz B) Location: something
text here C) more
CLINICAL DIAGNOSIS: xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}