re = /^(?:[^""';]*+(?:(?:"".*?"")++|(?:'.*?')++)?)*+[^;]*(;.*)$/mx
str = '$x = "eeee;"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end