# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/0(?=00)|(?<=00)0|(?<=0)0(?=0)/1/g;t' <<< "1001000001
1001
10001
"