using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0(?=00)|(?<=00)0|(?<=0)0(?=0)";
string substitution = @"1";
string input = @"1001000001
1001
10001
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}