$re = '/^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)/';
$str = ' 1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\\s{1})(\\s)(\\d*)(\\s)*(.*?)\\n((\\s{2})(\\d)(\\s*)*(.*?)\\n)[WITH]#$3# $5
$6';
$subst = "#$3# $5\n$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;