# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:call|CALL)[\ *](?:(?:system|\"system\").(?:runtime|\"runtime\").(?:kill_query|\"kill_query\"))"
test_str = ("CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n\n"
"CALL \"system\".runtime.\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"('20211003_215635_15007_n3mb3', 'afsd')\n\n\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')\n\n"
"CALL+\"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.