// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:call|CALL)[\ *](?:(?:system|"system").(?:runtime|"runtime").(?:kill_query|"kill_query"))"#).unwrap();
let string = "CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL \"system\".\"runtime\".\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL \"system\".runtime.\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL \"system\".\"runtime\".\"kill_query\"('20211003_215635_15007_n3mb3', 'afsd')
CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')
CALL+\"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}