using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Conference ID\D*([0-9]*).*";
string input = @".........................................................................................................................................
Join online meeting
https://meet.lync.com/p3group/ralf.klueber/XXXXXXXX
Join by Phone
+49696670000 (Dial-in Number) Deutsch (Deutschland)
Find a local number
https://dialin.lync.com/c52ce599-1156-4654-a150-ff021e3a0abc
Conference ID:
348054656
Forgot your dial-in PIN?
https://dialin.lync.com/c52ce000-0000-0000-a150-ff021e3a0abc
.......................................................................................................";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}