# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*Conference ID\D*([0-9]*).*"
test_str = (".........................................................................................................................................\n"
"Join online meeting\n"
"https://meet.lync.com/p3group/ralf.klueber/XXXXXXXX\n\n"
"Join by Phone\n"
"+49696670000 (Dial-in Number) Deutsch (Deutschland)\n\n"
"Find a local number\n"
"https://dialin.lync.com/c52ce599-1156-4654-a150-ff021e3a0abc\n\n"
"Conference ID:\n"
"348054656\n\n"
"Forgot your dial-in PIN?\n"
"https://dialin.lync.com/c52ce000-0000-0000-a150-ff021e3a0abc\n"
".......................................................................................................")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.