package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)ordernr[\r\n]+([^\r\n]+)`)
var str = ` 1. 21Sid1
2. Ordernr
3. E17222
4. By
5. Seller`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}