// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?six)ordernr[\r\n]+([^\r\n]+)").unwrap();
let string = " 1. 21Sid1
2. Ordernr
3. E17222
4. By
5. Seller";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}